Slow Scanning and Image Viewing

Resolved

This has been resolved in the short term.
Posted Oct 10, 2025 - 13:59 CDT

Monitoring

We have implemented a temporary fix that resolves the issue in the short term. A permanent fix should be coming this weekend.
Posted Oct 09, 2025 - 15:13 CDT

Identified

The slowness has returned.
Posted Oct 09, 2025 - 11:24 CDT

Monitoring

Updates were applied this morning. We'll keep monitoring.
Posted Oct 09, 2025 - 07:45 CDT

Identified

The slowness has returned.
Posted Oct 08, 2025 - 15:02 CDT

Monitoring

The slowness has resolved. We will continue keeping a close eye on it.
Posted Oct 08, 2025 - 14:44 CDT

Identified

The same issue returned as of 11:17am. We are pursuing other solutions. Thanks for your patience.
Posted Oct 08, 2025 - 11:37 CDT

Monitoring

We will continue to monitor the issues closely.
Posted Oct 08, 2025 - 06:46 CDT

Investigating

We are currently investigating this issue.
Posted Oct 07, 2025 - 13:32 CDT
This incident affected: Keli Cloud Services.