The issues have been fully resolved. Please let us know if you have any more issues.
Posted Nov 21, 2025 - 07:42 CST
Update
The majority of the fixes are in place. We are finalizing them this morning.
We are still working on recalculating all the payment plan details. This process ran overnight and is ongoing. Some counties may experience issues with case details appearing on payment plans until the recalculation finishes. We’re working to resolve this as quickly as possible.
Posted Nov 20, 2025 - 08:12 CST
Identified
We have identified the issue and have started implementing the solution. This should be fully resolved by the start of business tomorrow morning.
Posted Nov 19, 2025 - 14:05 CST
Investigating
We are aware of an issue where payment plans do not display the case details. Also, receipts were not being applied to payment plans. We are working to resolve this as soon as possible.