Slow Scanning and Slow Viewing Images

Resolved

The changes we made last are working well. We'll continue to monitor this going forward.
Posted Sep 22, 2025 - 12:09 CDT

Investigating

We are currently investigating performance issues with our imaging storage. No errors seen yet, but it is going very slowly.
Posted Sep 18, 2025 - 12:30 CDT
This incident affected: Keli Cloud Services.