Slow Scanning and Slow Viewing Images

Resolved

After a full day of no issues, we are marking this as resolved, but we'll continue to keep a close eye on it.
Posted Sep 16, 2025 - 07:10 CDT

Update

Work has been done to help resolve the issues, in addition to providing additional monitoring and debugging tools. We'll continue to monitor the issues over the weekend and into Monday.
Posted Sep 13, 2025 - 12:20 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 15:57 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 11:46 CDT

Investigating

We are currently investigating this issue.
Posted Sep 12, 2025 - 11:23 CDT