Slow Scanning and Slow Image Viewing

Resolved

After a full day of no issues, we are calling this resolved. We'll continue to monitor it closely.
Posted Oct 01, 2025 - 06:37 CDT

Monitoring

We have made some changes to the underlying storage in an effort to resolve the issue. We'll continue to monitor it closely.
Posted Sep 30, 2025 - 07:29 CDT

Investigating

We are currently investigating this issue.
Posted Sep 29, 2025 - 13:47 CDT
This incident affected: Keli Cloud Services.